Seaton Sound Discussion Forum
Register Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 6 of 17     «   Prev   3   4   5   6   7   8   9   Next   »
stevesatch

Registered:
Posts: 36
Reply with quote  #101 
Obie, were they bought prior to Nov of '08?
mojave

Registered:
Posts: 76
Reply with quote  #102 
I forgot that the first ones that failed were the second batch of V1 amps. I thought it was funny that when I sold my amps (both from the first batch of subs) I noticed that the amp board actually said v. 2. I wonder if the v. 1 amps were never sold and we might all be off by a number. Has anyone else seen this?
Murrel

Registered:
Posts: 39
Reply with quote  #103 
mojave,

In this case the board rev. has nothing to do with the amp rev. All V1 amp output boards were a through hole design. The V2 amp output board was a surface mount design. The power supply was the same for the V1 and V2. This power supply board was also used in the UFW/ULW amps with a few component changes. If you were to look at the power supply boards on a ULW/UFW they say MFW V2.

Murrel
obie_fl

Registered:
Posts: 42
Reply with quote  #104 
Steve - I think I took delivery in August 08 on my pair.  Only problem I had was a humm which I fixed by re-routing the internal cable in one of the boxes.  They shipped me an extra amp which I never took out of the box so I'm not sure of the vintage of the spare amp.  Every now and then it pays to be an early adopter I guess, but then again this was the bizarre world of AV123.
WWMTD

Registered:
Posts: 3
Reply with quote  #105 
I'm looking for a replacement amp for a UFW 12.  It's currently got a blown AV123 amp in it.  Any suggestions.  Thanks in advance.
sandbagger

Avatar / Picture

Moderator
Registered:
Posts: 524
Reply with quote  #106 
Is that the UFW-12HR upgrade kit(new amp and driver) from av123?


Quote:
Originally Posted by WWMTD
I'm looking for a replacement amp for a UFW 12.  It's currently got a blown AV123 amp in it.  Any suggestions.  Thanks in advance.

__________________
Kevin
Motor City Custom Audio
http://motorcitycustomaudio.com/
WWMTD

Registered:
Posts: 3
Reply with quote  #107 
I couldn't tell you, it's a hand me down sub.  I forgot to mention that it's a 500 watt amp.
gsr108

Registered:
Posts: 1
Reply with quote  #108 
For sale 2 satin black MFW-15, V2's, in the Houston area.  Both are still working.  Have the replacement caps, but have not had the time to put them on.  Looking to sell both for $400 firm. 

sandbagger

Avatar / Picture

Moderator
Registered:
Posts: 524
Reply with quote  #109 
Did you send me an email a few days ago?   Been working on a bunch of things and havent had a chance to get caught up on a bunch of email.

does  the amp has blue ends on the adjustments, a balanced input along with speaker connections and a red 110-220 input voltage switch.  The driver aluminum?

Does the person you got it from still have the original amp?

I have been working on the modifications needed to make the old amp work with the new driver.  Just finished that up tonight.
Quote:
Originally Posted by WWMTD
I couldn't tell you, it's a hand me down sub.  I forgot to mention that it's a 500 watt amp.

__________________
Kevin
Motor City Custom Audio
http://motorcitycustomaudio.com/
WWMTD

Registered:
Posts: 3
Reply with quote  #110 
I realize that I'm in the wrong thread now...

Quote:
Did you send me an email a few days ago?   Been working on a bunch of things and havent had a chance to get caught up on a bunch of email.

does  the amp has blue ends on the adjustments, a balanced input along with speaker connections and a red 110-220 input voltage switch.  The driver aluminum?

Does the person you got it from still have the original amp?

I have been working on the modifications needed to make the old amp work with the new driver.  Just finished that up tonight.

That was me that emailed you.  You are describing the right amp.  He does not have the original amp.  I think this was his third attempt and he got fed up with it.  I tried to see what was wrong with it today, but it blew the fuse as soon as I plugged it in. I've got it hooked up to an old receiver amp now and it sounds decent, but I'd like to have the auto on feature.

I can email pics if you like.  Thanks for your help with this.

stevesatch

Registered:
Posts: 36
Reply with quote  #111 
Anyone with a MFW15 for sale in Southern Ca?  MFW with version 3 amp much preferred.
mak99

Registered:
Posts: 77
Reply with quote  #112 
3/20/11:  SOLD SOLD SOLD

STOCK MFW-15 DRIVER AVAILABLE

(due to Turbo kit replacement that arrived today)

Just pulled this working driver from my MFW last week, due to recent v2 amp failure about a month ago.  Driver worked just fine for about a year of ownership before the amp got the dreaded hum/cap failure.  Smoke-free, pet-free, children-free environment.





Click here for more pics over on Picasa.

Wiring ends have the quick-connect still attached as I did not have to cut them when removing the driver.

PM me with questions!  100% FB on Ebay, Audiogon, AVS, etc.
mak99

Registered:
Posts: 77
Reply with quote  #113 
I also have the working controller (gain/frequency/phase) that I removed during the Turbo upgrade.  I do know the phase control works since I could see the effects on-screen using a Velodyne SMS-1, when I first bought the MFW in Feb 2010.

I thought I read somewhere where a few people commented that their phase control didn't seem to work correctly with the v1 and/or v2 amps?  I know this controller did absolutely nothing with the v3 amps, IIRC...



PM with questions, etc...
excaluber

Registered:
Posts: 15
Reply with quote  #114 
I hope sandbagger and Mark don't mind me sharing this but in the spirit of this thread I thought it might help some others.

Thanks to mojave's help I was able to get in touch with Mike from the av123 forums who makes the custom MFW grills.

He was very very very responsive throughout the whole process and really a great pleasure to deal with.  Anyone who's looking for upgraded grills, whether its for a better magnet (was the biggest reason I was), or just an updated look I recommend speaking with mike (loudnclear from av123).

Here's a couple of the after photos just for reference.







mojave

Registered:
Posts: 76
Reply with quote  #115 
Those grills look great. Both of my cloth grills have cracked in the middle because I was careless with them when the grills were off. I have a cherry sub with the threaded inserts and one without, too. I also have mine on their sides.
excaluber

Registered:
Posts: 15
Reply with quote  #116 
ya one of my grills cracked (i'm not exactly sure how).  But the magnets were to weak, everytime someone brushed up against the grill it hit the ground.  These new grills are much much stronger.  They won't come off even if bumped into.


Liaury

Registered:
Posts: 20
Reply with quote  #117 
I spy a Super Nintendo.
excaluber

Registered:
Posts: 15
Reply with quote  #118 
Original Nintendo actually

And its actually a computer inside a old nintendo case.  Sorta a little HTPC but with a cooler case imo

I do use it to play nintendo games though, I have a usb adapter for the original controllers.

mak99

Registered:
Posts: 77
Reply with quote  #119 
Hey, ex - how does the 'table perform when the MFW's are rocking??

BTW, your subs look great with LnC's custom grilles.  I also have the cherry diamond gloss finish (looks like from your pix?), so I just PM'd you for Mike's info...
excaluber

Registered:
Posts: 15
Reply with quote  #120 
Ya know what, I can't say i've ever had the system cranked when using the turntable.  I got it very recently.  I'll definitely have to give it a shot though.

My subs are actually just the Satin Cherry.  Which I do like quite a bit, but your diamond cherry looks pretty awesome.  That finish wasn't available when I ordered mine otherwise I think I woulda went for it.

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.