sandbagger Show full post »
nottaway
Still looking to buy an mfw amp controller module and wiring or two off anyone who doesn't need them......
AKA NicksHitachi
Quote 0 0
boober
nottaway wrote:
Still looking to buy an mfw amp controller module and wiring or two off anyone who doesn't need them......


Pure Evil at avs posted a message maybe about 2 weeks ago or so offering to give away the 1 or 2 that he had for free I believe. Send him a pm, hopefully for you maybe he still has them.
Quote 0 0
nottaway
Got my controllers......

Thanks for your help.....
AKA NicksHitachi
Quote 0 0
bmrowe
I've got a working MFW-15 w/ V2 amp in perfect shape and low usage for $400 plus shipping or local pickup in the Milwaukee area.

I've also got an MFW-15 w/ a failed V2 amp.  The sub is in perfect shape, just needs a new amp.  Make an offer.
Quote 0 0
tjcarst

WTB two v3 amps.

Quote 0 0
judah517

Does anyone with a dead V2 amp have any amp controllers that they would part with?

Quote 0 0
madtownjp
Seems like I can post this here
I want to get rid of 2 of the 4 MFW-15s

All are in Satin Black purchased in 11/2009. They have seen light use and are functional.  $350 + shipping ea / OBO from 53719

Quote 0 0
mojave
judah517 wrote:

Does anyone with a dead V2 amp have any amp controllers that they would part with?



I purchased a subwoofer at the av123 auction. It didn't have an amp and I don't need the amp controller because the sub is scheduled to become a Turbo.
Quote 0 0
Toxis
I too have an MFW-15 with the dreaded hum.  Anyone have an amp available? Pretty sure my controller is OK and the driver is flawless so the amp alone should be enough.  I emailed AV123 per his site as he says anyone needing amps to contact him but I want to see if there's other options as well.  I greatly appreciate any help!  I don't have the cash to do the Turbo upgrade for probably another year at the earliest and really miss my sub.

Email is Toxis2k@gmail.com
Quote 0 0
sandbagger
If you can solder this is a cheap and easy fix until we come out with the drop in amp.

http://www.avsforum.com/avs-vb/showpost.php?p=19431056&postcount=1195

Toxis wrote:
I too have an MFW-15 with the dreaded hum.  Anyone have an amp available? Pretty sure my controller is OK and the driver is flawless so the amp alone should be enough.  I emailed AV123 per his site as he says anyone needing amps to contact him but I want to see if there's other options as well.  I greatly appreciate any help!  I don't have the cash to do the Turbo upgrade for probably another year at the earliest and really miss my sub.

Email is Toxis2k@gmail.com
Kevin
Motor City Custom Audio
http://motorcitycustomaudio.com/
Quote 0 0
ripcordaff
Hello guys,

For sale is a rosewood MFW-15. Cosmetically perfect. Driver is in perfect condition. v2 Amp developed hum, sent to Murrel for cap fix. He fixed it, but I accidentally popped a wire out of one of the amp board connectors when I was trying to get it back together. Truth be told, I am trying to get rid of this whole wretched thing. So, for $300 OBO you get

1)rosewood (perfect finish) MFW
2)perfect driver
3) Murrel cap-fixed v2 amp that ostensibly works (just have to reconnect\splice) the wire back on the white connector thing

$300 OBO, location is Iowa City, IA or Kansas City

Thanks!

Ripcordaff@gmail.com

Edit--seriously, all offers considered. 
Quote 0 0
CombatChuk
Got a Cherry Diamond MFW-15 for sale...  The Cabinet is in good shape so is the driver.  The AMP (Hasn't been modified) does not hum but due to my toddler screwing around in the back of it, he broke off the connectors for the LFE and Right Input.  The Sub is currently running fine going through the Left input.

I'm in Denver, CO and ready for someone to take this off my hands!

$250/obo
Quote 0 0
excaluber
Heya, 

I just wanted to say thank you, this forum has been great.  I've been reading it off/on since the av123 was still around but just never posted.

Anyways, I was wondering does anyone knows how to get ahold of LoudnClear from the av123 forums?

I was looking to buy 2 of his custom metal grills for the mfw-15.  Or if anyone here has them for sale, i'd be interested in buying them.


Quote 0 0
mojave
I just PM'd you his e-mail address.
Quote 0 0
excaluber
Thanks for that, I really appreciate it.

I've been in contact and I'm gonna pick two of them up.
Quote 0 0
Sepen
I am looking for the board that goes on the amp that Murrel replaces the caps on. Mine is shot and that is the only part that I need. Thanks.
Quote 0 0
Murrel
Sepen wrote:
I am looking for the board that goes on the amp that Murrel replaces the caps on. Mine is shot and that is the only part that I need. Thanks.

I have about 6 left.

just email me your address and I will send you one.

Murrel
simplysound@msn.com
Quote 0 0
Sepen
Check your PM Murrel, thanks.
Quote 0 0
Murrel
Sepen wrote:
Check your PM Murrel, thanks.

I did and replied.
Quote 0 0
stevesatch
Message sent to jparkhur and deal made. 
Quote 0 0
mojave
stevesatch wrote:
I curse the version 1 and 2 MFW15 amps : )  Thanks jparkhur.

I own two MFW-15's with version 1 amps that worked fine . . . until I sold the amps and got the Turbo kits (still waiting on 2nd kit). I have never heard of anyone having problems with version 1 amp at av123's forum, AVS, or any other forum I've been on.
Quote 0 0
Timeless_Tech
mojave wrote:
stevesatch wrote:
I curse the version 1 and 2 MFW15 amps : )  Thanks jparkhur.

I own two MFW-15's with version 1 amps that worked fine . . . until I sold the amps and got the Turbo kits (still waiting on 2nd kit). I have never heard of anyone having problems with version 1 amp at av123's forum, AVS, or any other forum I've been on.


Maybe you were lucky enough to have V1 amps from early production, before the manufacturer started implementing shortcuts (failure-prone components). I waited forever for one of the Chinese-built Rosewood MFW-15s, whose V1 amp failed within months. MLS's crew replaced it with another V1 amp that also failed within a similar period, and finally a 3rd amp (V2 this time) that ultimately failed as well.

I've implemented Murrell's greatly appreciated fix on all 3 amps, but the V1s still need more work. At least I'm no longer boomless until I get back to those V1s. One of the parts I'll be ordering for 'em are fuses for the IEC power connector. If better insulating the edge of the Power Supply Board from the back plate of the amp resolves the fuse blowing issue, there will still be additional repairs needed for one of the other boards to eliminate the hum.
Quote 0 0
Liaury
I agree there was probably two versions of the V1 amp.  LOL

I have three V1 amps that failed.

Quote 0 0
stevesatch
Early version 1 amps are solid.
Quote 0 0
obie_fl
Two V1's still running strong here and a third unused in the box.
Quote 0 0

Add a Website Forum to your website.